133 utenti online in questo momento
133 utenti online in questo momento
Dubbi e domande relativi a Google Tag Manager.
Guidami
star_border
Rispondere
Highlighted

Tracking Youtube ha smesso di funzionare.

Matricola ✭

Buongiorno a tutti! 

Ho un problema: 2-3 settimane fa ho inserito il tracking degli eventi per i video di youtube sul mio sito cavia-di-laboratorio. Ho testato e ritestato in ogni modo, e funzionava perfettamente. 

Oggi sono andato a lavorarci nuovamente, e senza che io ci abbia fatto niente non funziona più: come da immagine, per quanto io possa cliccare a oltranza sul video non appare niente neanche nell'anteprima di GTM nè sul datalayer. 

 

Idee su cosa possa averlo causato? Grazie mille! Manca qualcosa.PNG


Soluzioni accettate
Selezionata come risposta migliore.
Soluzione
Accettato da autore argomento Tommaso V
‎17-04-2018 14:40

Tracking Youtube ha smesso di funzionare.

Matricola ✭

UPDATE: 

Problema risolto. 

Ho ripristinato il tutto a 11 gg fa, ed è tornato a funzionare correttamente quindi non era un problema di impostazioni di GTM. 


Sospetto che il problema potesse essere a causa di AMP che bloccava javascript, ma non sono riuscito a risolvere il problema nè togliendo quello nè tutti i plugin, immagino ci fosse rimasto qualche strascico. 

Visualizza soluzione nel messaggio originale


Tutte le risposte

Rif.: Tracking Youtube ha smesso di funzionare.

[ Modificato ]
Matricola ✭

Update: Ho smanettato un po, e messo un video Youtube su un altro sito wordpress di prova. 
Anche li ho configurato le variabili video di youtube, aggiunti i trigger, verificato che le impostazioni siano uguali, e funziona alla perfezione. 
Indagando un pò ho notato una differenza:


Video sito 2: Tracking funzionante
<iframe width="660" height="371" src="https://www.youtube.com/embed/6wDSFQFKSo0?feature=oembed&amp;enablejsapi=1&amp;origin=http%3A%2F%2Fnomedeltuoblog.altervista.org" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen="" data-gtm-yt-inspected-0000000000="true" id="000000000"></iframe>

 

Video sito 1:Tracking non funzionante: 

<iframe width="500" height="281" src="https://www.youtube.com/embed/1u4xAB_-J74?feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen=""></iframe>

Parrebbe quindi che il problema derivi dal mancato supporto API Javascript sul video: 
E infatti andando sul blog con video funzionante, e rimuovendo la spunta il supporto API JS da GTM ottengo questo 


Video sito 2: Tracking NON funzionante 

<iframe width="660" height="371" src="https://www.youtube.com/embed/6wDSFQFKSo0?feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen=""></iframe>

E come per l'altro, non vengono più registrati gli eventi video. 

 

Il punto è che su entrambi i GTM ho le stesse impostazioni, ed entrambi sono siti wordpress fatti su Altervista quindi non mi spiego perché su uno si attivi e sull'altro no. 

Controllo che non ci sia qualche plugin di sorta che interferisce

 

 

 

Selezionata come risposta migliore.
Soluzione
Accettato da autore argomento Tommaso V
‎17-04-2018 14:40

Tracking Youtube ha smesso di funzionare.

Matricola ✭

UPDATE: 

Problema risolto. 

Ho ripristinato il tutto a 11 gg fa, ed è tornato a funzionare correttamente quindi non era un problema di impostazioni di GTM. 


Sospetto che il problema potesse essere a causa di AMP che bloccava javascript, ma non sono riuscito a risolvere il problema nè togliendo quello nè tutti i plugin, immagino ci fosse rimasto qualche strascico.