49 utenti online in questo momento
49 utenti online in questo momento
Guidami
star_border
Rispondere

Monitoraggio non installato: cosa sto sbagliando?

A T
Matricola ✭

Ciao a tutti e grazie in anticipo per il supporto.

 

Ho un problema con Analytics su un sito in wordpress,

il monitoraggio non risulta installato.

 

Ecco quello che ho fatto.

 

Ho modificato il file header.php del mio template aggiungendo prima di </head> il seguente script

<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-XXXXXXXX-1', 'auto');
ga('send', 'pageview');

</script>

 

La modifica sembra essere corretta perchè, andando in qualsiasi pagina del sito, e visualizzando la sorgente pagina, vedo lo script correttamente posizionato prima di </head>

 

Nonostante ciò facendo l'accesso al mio account GA nella sezione "codice di monitoraggio" lo stato è "monitoraggio non installato".

 

Cosa sto sbagliando?

 

Grazie mille per l'aiuto.

 

A.T. 


Soluzioni accettate
Selezionata come risposta migliore.
Soluzione
Accettato da autore argomento A T
‎02-09-2015 01:38

Rif.: Monitoraggio non installato: cosa sto sbagliando?

Laureato ✭ ✭ ✭
Se l'iconcina di Tag Assistant diventa verde vuol dire che il codice funziona.
Anche io ho un sito che riporta il messaggio "monitoraggio non installato", ma funziona sia il tempo reale che le statistiche, è passato un mese e ancora mi dice così, non ho fatto altro.
Quindi non ti garantisco che nel tempo cambierà il messaggio, ma prova oggi a vedere se nei rapporti ci sono le visite che hai fatto ieri, diversamente al tuo posto penserei di utilizzare un plug in.

Visualizza soluzione nel messaggio originale


Tutte le risposte

Rif.: Monitoraggio non installato: cosa sto sbagliando?

Matricola ✭ ✭ ✭
Ciao,
lo script che hai incollato qui sopra è lo stesso che hai inserito nel codice HTML ?
Se si, allora qui ti manca il tuo codice personale di monitoraggio
ga('create', 'UA-XXXXXXXX-1', 'auto');
che va inserito al posto di UA-XXXXXXXX-1

Questa guida ti spiega dove trovarlo:
https://support.google.com/analytics/answer/1032385?hl=it

ciao
Dario

Rif.: Monitoraggio non installato: cosa sto sbagliando?

Laureato ✭ ✭ ✭
Un saluto a entrambi,
presumo che le XXX di AT siano un modo per oscurare il codice di monitoraggio del suo sito web.
In genere per inserire Analytics su Word Press si può utilizzare il plug in Analytics by Yoast e l'operazione è abbastanza semplice, ma nulla vieta di inserirlo manualmente.
Potresti fare una prova del funzionamento del codice di monitoraggio con l'estensione Google Tag Assistant, ma potrebbe essere anche un problema di tempo.
Intanto ti invio un mio articolo al riguardo, magari trovi una soluzione anche senza fornirci il sito di riferimento https://www.it.adwords-community.com/t5/Articoli/FAQ-Analytics-1-Come-faccio-ad-inserire-il-codice-d...

Buona giornata Smiley Strizza l'occhio

Rif.: Monitoraggio non installato: cosa sto sbagliando?

A T
Matricola ✭
Ciao grazie per la risposta,
Ovviamente al posto delle xxxxx c'é il mio codice di monitoraggio,
Copiato direttamente dal mio account GA.

Il codice sono sicuro che é corretto...

I problemi peró rimangono purtroppo......

Smiley Triste

Rif.: Monitoraggio non installato: cosa sto sbagliando?

Matricola ✭ ✭ ✭
Allora come dice Mariella sarà una questione di tempo...

Rif.: Monitoraggio non installato: cosa sto sbagliando?

A T
Matricola ✭
Ciao grazie anche a te per la risposta.

Ho provato ad installare tag assistant come da te suggerito, non conosco lo strumento quindi mi guarderò qualche uida per capire a cosa serve.

Intanto ti posso dire che aprendo il mio sito e cliccando sull'icona di tag assistant in chrome succede:
l'icona si colora di verde
mi viene mostrato il mio codice di monitoraggio UA.......

Altra cosa che potrebbe aiutarci nella comprensione
se vado nelle analisi in tempo reale sembrano funzionare,
nel senso che mi collegandomi al sito da un altro device, analytics capisce che c'è un nuovo utente che sta osservando il sito....

Probabilmente come dite voi sarà solo questione di tempo?

Vi aggiorno domani per capire come si evolve la situazione!

Grazie ancora per i suggerimenti.

AT
Selezionata come risposta migliore.
Soluzione
Accettato da autore argomento A T
‎02-09-2015 01:38

Rif.: Monitoraggio non installato: cosa sto sbagliando?

Laureato ✭ ✭ ✭
Se l'iconcina di Tag Assistant diventa verde vuol dire che il codice funziona.
Anche io ho un sito che riporta il messaggio "monitoraggio non installato", ma funziona sia il tempo reale che le statistiche, è passato un mese e ancora mi dice così, non ho fatto altro.
Quindi non ti garantisco che nel tempo cambierà il messaggio, ma prova oggi a vedere se nei rapporti ci sono le visite che hai fatto ieri, diversamente al tuo posto penserei di utilizzare un plug in.

Rif.: Monitoraggio non installato: cosa sto sbagliando?

A T
Matricola ✭
Grazie a tutti per l'aiuto.

Effettiavamente senza fare nulla diparticolare adesso lo stato è di "Ricezione Dati",
quindi effettivamente ci voleva solo qualche giorno di attesa.

Grazie ancora
AT